登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

天道酬勤 玩物丧志

用勇气去改变可以改变的事情,用胸怀去包容无法改变的事情,用智慧去判断两者的区别

 
 
 

日志

 
 

DM365文件系统问题  

2010-09-03 18:01:03|  分类: 达芬奇DM355/365 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

      我们的DM365开发板,将文件系统固化到flash中,连基本的encode程序都无法运行

出现的错误代码:

./encode: /lib/tls/libpthread.so.0: version `GLIBC_2.4' not found (required by .
/encode)
./encode: /lib/tls/libpthread.so.0: version `GLIBC_2.4' not found (required by /
usr/lib/libasound.so.2)

 

是我在nfs下的编译的应用程序所用的库版本和开发板商提供的文件系统的库版本不一致。。。

于是,将库拷贝。。。出现文件系统无法正常运行。。。

 

在TI官网下载到了最新的dm365的rootfs文件系统,只有11M不含应用程序,但是,将程序考到文件系统中固化到板子上后,运行encode

报segmentation fault。。。

 

用busybox1.15.3定制文件系统,发现生成的文件系统,整个大小只有几M,但是进bin全选可执行程序-右键-属性,发现有100多M。。。

  评论这张
 
阅读(822)| 评论(0)

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018